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AIM Your Project with Flash: Flash QuickStart Workshop

Explore & Evaluate Flash Projects

Explore Flash projects from the list found at http://eduscapes.com/flash/explore.htm

Before you jump into evaluation, be sure to record background information about the evaluation
environment: project name; summary of audience, purpose, contents; URL or access point; oper-
ating system and web browser, version of Flash plugin, date of evaluation.

Overall Impressions

Is this project a good use of Flash?

Would an animated gif be just as effect?

Would a movie be as effective?

Would a still graphic be as effective?

Would a text page with graphics be as effective?

Is the overall project appealing and inviting?

Is the project an effective model for other developers?

Does this project offer content or an approach not available elsewhere?

Audience and Purpose

Is the project purpose and sponsorship immediately clear?

Is the “look and feel” of the project appropriate for the audience and purpose?
Does the project address the demographics of the primary audience?

Does the project address the needs or interests of the users?

Is the project flexible enough to accommodate varied learning styles?

Are the materials developmentally appropriate for the primary audience?

Content

Are informational, persuasive, and/or teaching strategies applied effectively?

Does the project contain accurate, high quality content (i.e., interesting, useful resources)?

Is the authority of the project clear?

Is the content objective, opinions identified, and perspectives balanced?

Are authentic resources used (i.e., quality graphics, established sources, primary materials)?
Is the content timely and current?

Is the content relevant, useful, and meaningful to the intended audience?

Is the content presented in an efficient and effective manner?

Is the breadth of the content effective (i.e., goes beyond basic facts and data)?

Does the depth of content match the varied audience needs (i.e., text explanations, audio,
choices for more depth)?

Does the project provide resources that go beyond the ordinary (i.e., unique, local, special)?
Does the project contain a mix of content formats (i.e., text, graphics, photographs, video, au-
dio) to address specific needs?

Is the content logically organized?

Does the project contain current, timely information?

Is the project free from spelling, grammatical, and other typographical errors?

Is any writing clear and appropriate for the developmental and reading level of the audience?
Is the content presented in a variety of ways to meet individual differences (i.e., text, graphics,
photographs, diagrams, audio, video)?

Is there quality content beyond links?

Organization

Does the project contain a clear introduction and organized elements?
Are events presented in a logical sequence?
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Design
Is the project visually appealing?
Do audio elements contribute in a positive way?
Do the colors attract rather than distract?
Is adequate contrast provided between elements in foreground and background?
Is the project creative and imaginative?
Does the project maintain audience attention?
Does the project have an effective introduction?
Does the site make appropriate use of fonts (i.e, font type, style, size, color, ease of reading)?
Were fonts effective and easy to read?
Were font colors appropriate for ease of reading?
Does the project make effective use of foreground colors, background colors, and/or images?
Is the visual layout effective and visually appealing?
Does the graphic design reflect the purpose of the site (i.e., serious, whimsical, visually inter-
esting)?
Is the design attractive for the intended audience?
Is there a consistent theme or layout throughout the project?
Does the graphic design add to (not distract from) the site?
Is the visual layout consistent, well-organized and free from clutter?
Navigation
Are directions or help provided for use of icons, navigation, or interactive elements?
Is effective navigation (i.e., menu, buttons, limited options) provided as needed?
Are helpful information retrieval tools (i.e., site map, index, search engine) provided?
Is the navigation appropriate for the audience?
Technical - Overall
Does it load quickly and provide information about loading time?
Does it flow smoothly from start to finish?
Do all graphics, animations, text, and other page elements appear in their proper places?
Are directions provided for running or using the project?
Are directions provided for downloading the Flash plug-in?
Are transitions smooth, consistent, and not distracting?
Technical - Animation
Does the animation contribute to the effectiveness of the project?
Does animation attract rather than distract users?
Is animation used in meaningful ways?
Technical - Interaction
Does the interaction contribute to the effectiveness of the project?
Do interactive elements function effectively?
Do interactive elements contribute to understanding rather than confusion?
Is feedback or the result of interaction clear and effective?
Technical - Multimedia
Does the multimedia contribute to the effectiveness of the project?
Are media attributes used effectively without being distracting?
Do the media elements address alternative learning styles?
Were media elements clear and easy to understand and/or interpret?
Accessibility
Do the materials meet the requirements of special needs users in the primary audience?
Do the materials meet the Section 508 accessibility standards?
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Build a Hot Air Balloon P

Open Adobe Macromedia Flash. (Flash 8 instructions)

Create a new Flash document (blank workarea is called the Stage). \ y

Save the document (to desktop, thumbdirve, etc.) and give it unique name. R
Use Graphic Tools |

Let’s create a hot air balloon using the graphic tools (Begin at Layer 1, Scene 1). .

Use the Tools Palette to create one balloon with a gondola basket.

Suggestions: | Tosts
Use the rectangle tool (Tools Palette) to make a box-shape - basket of hot air balloon.  |* "
Select Oval tool and draw a oval for your hot air balloon. g
Use the Pencil and other tools to complete the balloon. ;
Also use Stoke and Fill color to help add to it's unique appearance. :

You can spend a lot of time creating and embellishing artwork. # _}
Don’t forget to frequently save your work. & &

Timeline | ' % Scene 1 y ]

Create a Graphic Object aca0 ||
Let’s turn our balloon into a graphic object we can reuse [ Layer 1 7+ + O & cr,_;'
from the Library. s el m i |

A S

With the Selection tool, select the entire hot air balloon figure.

Under the Modify menu, select Convert to Symbol.

Name your graphic and click / select Graphic under Type. Click OK.

Name given to your hot air balloon graphic is now shown in the Library.

As you create and add other graphic images (cloud, bird) in a Flash program, you should save
them to the library as another graphic object.

Images can be imported from other graphics programs, clip art libraries, and copy pasted into
place in Flash - - usually given their own Layer.

Once in the Library, they can be used over and over again.
Save your work..

Setting the Length
To use our hot air balloon graphic in a short Flash movie, we need to decide how long our
movie will be ... usual frame rate is 12 frames per second.
Let’s start with 120 frames for a 10 second movie. — Froi TR
120 120
Click on frame 120 in the our first layer _l : IIII '
(if there are other layers, shift click on each/al) - as selected they turn gray.

Pull down Insert menu, choose Timeline, and select Frame.
Niotice the last frame (120) now has a white rectangle and the layer(s) are gray,
indicating they now contain content - - your static balloon on every frame, but still it's there!
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Animation
Make the Balloon Rise

Let’s use animation to make your hot air balloon rise up into the sky.

There are different ways of creating animation including: (1) frame-by-frame (labor intensive

but can be very effective), (2) motion tweening (set beginning and end points and letting the

computer complete), (3) shape tweening (computer morphs one shape into another), and (4)
ActionScript (using ActionScript programming to move objects.

Creating Motion Tween Animation

The most common and perhaps easiest method for Flash animation is motion tweening.
(Note that you can only use graphic symbols (the balloon image) and movie clips for motion
tweens.) Steps for using motion tween to make the balloon rise:

Select frame120 on the layer with your balloon image.
Pull down the Insert menu, select Timeline, then select Keyframe.

Notice the black dot indicating the Keyframe.
Make sure that your layer with the balloon is unlocked (no lock on the layer).
Next, drag the balloon to a final position in the upper part of the Stage - directly above itself.
A Motion Tween will span the space between the starting point (Frame 1) and Frame 120.
The Tween programming is associated with the Keyframe starting point.
Therefore, click Frame 1 of the layer (ballroom).
Go to the Windows menu, choose Properties. (it may already be below the Stage)
Look for Properties panel, choose Motion from the Tween drop-down menu.
(Notice that an arrow on the layer timeline now connects the  FE—dr—— .
starting Keyframe to the end Keyframe.) 5 ||L15 120
If you haven’t done so recently, save your work. s s

The Flash software has automatically moved the object frame-by-frame in a direct path from
the starting point to the ending position. Take a look at what you have done by pulling down the
menu headings under the Control tab, select Test Movie (Also called Test the swf File) to cre-
ate the swf file.

Modify the Balloon Path
Pretty cool! Look what you have done! Consider different movements; instead of straight up.
You could have specified a different stage location for your animation ending.
But movement would stll be limited to a direct path created by the computer.
Instead let’'s move the balloon sideways, or in other varied patterns by other methods.

Using a Motion Guide | Timeline | | g scene1
Taking the Flash program that you have already created, &

let's modify it using a Motion Guide: — =*ald

L i DO

Click on the layer that has your balloon image. - LA bl T i D!
Click the Add Motion Guide button * @ i 6 bl -

above the Stage on left side below the main Timeline. .
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You have just created a Guide layer as a subset of your balloon layer.
(This new Motion Guide layer appears above the other).
Again, you first set the end point (frame) for this guided motion.
In the Guide layer, click on Frame 120.
Pull down Insert menu, choose Timeline, select Keyframe to set the end point.
On the Guide layer, select Frame 1.
For this to work, your image must be a (graphic) Symbol (Shown in the Library).

Ready to create a path for your Motion Guide?

Select the Pencil (or Pen) Tool Q and click on the exact center of the balloon (On the stage).
You can use the Selection Tool to grab and display that center of the balloon image. But
remember to draw your path with the Pencil / Pen Tool, you have to return to Frame1 of
your Guide layer.

Starting at that balloon center, draw a path on the stage for your balloon to follow - from the
beginning to end point. Get the start and end points as close as possible. The type of line
and the technique used to complete the line are different for each tool (Note that if you use
the pen, you have to click end points for each line segment, connecting each to the next.

When your path line is drawn, switch to the Selection Tool. Click in the first frame of the Layer

where your balloon is located. Adjust the position of the balloon so that the dot in the middle of

the selected area is at the beginning of your motion guide. Do the same on Frame 120.

If it still does not work, make sure the Snap to Objects is selected under the View > Snapping
menu.

Note: There are two ways to preview your Flash movie. (1) On the Timeline, drag the Playhead
from start (Frame1) to finish. This is called “scrubbing” the timeline.
(2) Pull down the Control menu and choose Test Movie.

Create and Animate Fireworks Using Shape Tween
In the interest of time, your Flash program is relatively sparce.
But if you wanted to, you could easily add building(s), tower(s) - - a cityscape, clouds, a sun,
grass, a sky background, and various other elements to the stage. You can draw your own
artwork as you did with your balloon, and you can import line art or clip art.

To gain one more animation technique for your Flash works, let’s try creating an exploding
firework in part of that blank Stage space. Go with us here; these are supposed to
look like exploding fireworks - - don’t they?

Here the guidelines are going to be fairly flexible.
Create a new layer for this . . . and select / click on that layer.
(Name it whatever you like . . .)
Select a segment of 30-45 frames -
(60 t0 95, 70 to 115, 45 to 75 or something similar)
Within the new layer, click on the frame number of your selected starting point.
Create the beginning of your fireworks display: under Insert, select Timeline and Keyframe.
Click on the small circle to the right of the rectangle icon of the Keyframe (Within the layer).
Now you are ready to draw your first image of a firework explosion . . .
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In the clear, open space of your stage - - draw your exploding fireworks.
(Can be series of lines or a shape drawn by pen or pencil tool)

Think of this fireworks as the first stage of it's explosion, adjust the size using the
Modify > Transform > Scale menu.

Do not group the image, select/grab all of it and play around with editing line thickness,
colors until you have something you like.

(You should save a copy in the Library with unique name).

Leaving your first fireworks image upgrouped, now draw or copy/paste a second image of what
you imagine the final look for of your fireworks. This can be just a larger version or an
entirely different image.

When you have the second fireworks image as you like, also save it to the library.

Once saved, you can delete it from the stage at the starting point frame - should have your first
version there, ungrouped, in the location that you want it to appear.

Select your end point and Insert > Timeline > Keyframe, click on the circle icon and paste in
your second fireworks explosion. Check that the image has been broken apart
(ungrouped): Modify > Break Apart

Return to the starting point in the layer, click on the circle icon for the Keyframe.

Look below the Stage for the Properties window; if it's not there (something else in place -
Click a second time on the circle / Keyframe.

[# w [ properties | Filters ' Parameters

| l! Frame Tween: 75};2715&; S
<Frame Label> Ease: 0 ‘7‘

L

Label type: Blend: | Distributive _?]

Name

In the Properties panel, choose Shape from the Tween drop-down menu.
Select Angular Blend or Distriubted Blend type.
Scrub the Timeline to see your results.

Interaction

In Flash, it's also possible to create interactive components to make your project interactive.

Regardless of the type of interactivity, an authoring language called ActionScript is used.

All interactions have two elements: events and actions.

Events are the triggers while a Flash program is playing; i.e., a button is clicked to have a
sound play, or cuase other parts to appear or disappear, or cause data to be sent ot a
database.

ActionScript coding can be placed in two areas of a Flash project: (1) on frames on the
Timeline and (2) objects on the Stage (i.e., buttons, symbols).

The Flash software contains a collection of prewritten scripts for common actions. This allows
you to incorporate some interesting interactive elements before learning how to directly code
ActionScripts.
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Adding an ActionScript
You may have noticed that your Flash movie plays over and over again in a loop.
To stop the program after it plays, need to add an ActionScript. To do that:

Create a new layer; call it action.

Select Frame 120 on the action layer.

Add a keyframe by clicking on Insert > Timeline > Keyframe. (Reminder that we have to
have a keyframe in any location that you want information to appear or have something
happen)

With the keyframe (Frame120 on the Action layer) selected, pull down the Window menu.

Select Actions.

The Action panel will appear on screen. You canchoose the command or write it directly into

the script. If you do not see a list of ‘books’ beneath
ActionScript 1.0 & 2.0, find the small triange (centered) and click to open / expand.

Click on the Global Functions book.

Next, click Timeline Control followed by doubleclicking on the stop command.

The script for a stop command now appears in the programming window.

If you prefer to type the code, simply write stop();

It is part of your Flash program (Below).
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Test your Flash movie; it's should play through one time and stop on the last frame.

Link o a Website
In Flash you can and will probably do some code or scriptwriting yourself, paricularly if you
work extensively with the program. However, you can create lots of interesting actions using
prewritten scripts for common actions.

Let’s try another technique to create a hyperlink in our Flash program that takes the viewer to
more information about hot air balloons - - a website resource.

There are lots of good websites about hot air balloons such as:
How Hot Air Balloons Work by T. Harris at howstuffworks
http://travel.howstuffworks.com/hot-air-balloon.htm
Hot Air Ballooning http://www.hotairballooning.com/
Or another site you prefer? . . . http://www.fireworksafety.com/
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Using a Ready-made Button

Create a new layer named buttons; click on Frame120 within the layer, add a KeyFrame.
Pull down the Window menu, choose Common Libraries, and select Buttons.

You will see a list of folders.

Double-click on a folder - - to see different versions of buttons in varied colors.

Select and drag a button onto your Stage.

Note: You must have a KeyFrame in a Layer to place an Action. You cannot put two actions
on the same Frame of any layer; therefore you sometimes have to create another layer.

Still in Frame 120 of your button layer with the button on the stage selected:
Pull down the Windows panel, select Behaviors.
Behaviors are prewritten scripts for common actions.
Within the open Behaviors panel, click the plus sign.
Choose Web, and then Go to Web Page.
Enter the website address and click OK.
Save your work, and test the movie (under Control, click on Test Movie).

You can edit the default text on the buttion, but you have to use the Text o
tool and have the button unlocked Co 1o URL
(double click to enter the Symbol Edit- | o
ing mode). R : '
. Cancel ‘ ax ’ .:
Coding a Button :

If you have time, consider adding one more button - - again on Frame 120. It can be on the
same button layer with our weblinked buttion.

You need to copy / place another button on the stage. Note: You must use a different button

than before; if the two are identical, the associated behaviors will be attached to both. We want

this second button to replay our Flash program. Therefore you need to select a different button

(Could be different color of the same style)

Note: In editing text on a ready-made button, you can change replace / change the font, style,
size, etc. Likewise you can select and scale the size of the button.

Select the new button.
Pull down the Window menu, choose Actions.

The Action panel will appear. This time - have to enter a script by hand.
Click in line 1 of the Script pane.

Type the following script (Lines 1-3 to be keyboec s imam = s =
| | AmtisaSerise 10420 3 PN st A
on (release) { B oo Eorecea B Ccindiorc)
gotoAndPlay(1); ) b dousle goid H)
< wene L
} ol sction Trame
& TU0¢ COUdie noae

Save your work, test the movie.

']rma-u-.-n[;
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Multimedia

You can insert both audio and video into your Flash works. However you cannot create / record
audio and and video components within Flash. Rather you can create and edit these elements
with other software tools and then incorporate them into your work. Reminder that multimedia
components should not be viewed or used as “extras” or supplements to be added as time
allows. Instead audio, video and visual elements should be planned as integral components
created to meet particular needs; i.e., address needs or interest, information, instruction, etc.
Users’ ability to hear and see multimedia components can be dependent on installed players
and plugins on their computers.

From music clips to sound effects, there are a variety of ways to incorporate sound into a Flash
project. Would you like to add a fireworks sound effect to your project?

If so, go to the Find Sounds website at http://www.findsounds.com/
Search for ‘firework’ and select a sound; download (copy) one that you like to your desktop.
To download, right-click on the sound icon and choose Save Link As.

Note: You can import several formats of audio files including *.wav, *.mp3, and *.aiff. A wav file
works well for brief sound effects, but on longer audio clips you may have better sucess with
the mp3 format.

Add Fireworks Sounds
Next step for using the fireworks sound in your Flash project is to import it into the Library:
Click on the Stage or a Keyframe in the Timeline.
Pull down the File menu, choose Import, select Import to Library (A dialog box will appear).
Locate the sound you have on the desktop.
Select and click Open.
Nothing changes on the desktop, but the sound file is added to your Library.

-

T e

To embed this sound in the project, you should create a new Layer called sound.

Select where you want the sound effect to begin playing and click on that frame in the sound
layer.

Add a Keyframe on the layer.

With that Keyframe selected drag your sound file from the Library onto the Stage.

Save the project and test your Flash movie.

Sound files can also activated by button(s) and ActionScripts in your Flash work. Consider
what other sound files could contribute to your project.

Flash Video

Video is an excellent way to add movement to your projects. It can provide closeup, larger-
than-life views and is essential in situations where motion content is critical. Video can also
contain audio elements, be used without a soundtrack, or have added voiceover narration and
sounds.

The Flash software can import or create Flash video (.flv) files. With QuickTime software in-
stalled on the computer, *avi, *.mpg, *.mov, and *.dv video files can be imported. Short-length
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Recommend that you try to keep video clips down in length to about 10 seconds, and also limit
there image size - - to avoid overly large files and difficulties in moving and playing them via
the Web. If longer videos are needed, consider streaming video from a web server with the
needed video capacity. Video can be streamed from a specialized Flash video server.

From Flash programs that you create locally, you can connect to an .flv video played from a re-

mote web server. An added benefit is that the long video program can be setup to begin play-
ing while the download is still in progress (Fast-start video).

Publishing
Type Types

You can save your project as an FLA or SWF file. These can be easily shared.

The FLA file (Macromedia Flash Project file) is a uncompressed source Flash file that contains
all animation and graphic. An important factor about FLA files are that they are editable.

SWEF files are typically derived from a FLA file. SWF files are proprietary vector graphics files
produced by the Macromedia Flash software. SWF files are compressed and uneditable. An-
other important factor is that they contain the embedded fonts from the original FLA file.

A SWF file automatically generated when you test the movie. It can also be created by export-
ing the file.

Embed in web page

We can link to our file on a web page. We can also embed an SWF file.

Your Own Project

This handout provides a QuickStart to Flash. We recommend that you complete all of the read-
ings and activities at the Flash website for a more comprehensive look at Flash Basics.

http://leduscapes.com/flash
When designing your project, we find that it's helpful to do some drawings. Some people like to

use post-it notes or cards. Others simply jump right in. Either way, it's important to plan. Who is
your audience? What do you want to say? How will end-users interact with your project?



